Announcement

Collapse
No announcement yet.

ASTRA Docking request glitch? ((left panel))

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ASTRA Docking request glitch? ((left panel))

    Hello. So I bought and installed ASTRA 2.4 (Full House), and commands involving the left panel tend to give me issues mid-game (by that, I mean they work and then they don't in the same session). Then, even with restarting both VA and ED, they still won't work.

    I'll use Docking Request for my example. The ONLY modifications I made to "docking request" was to add more commands, such as "let's land", or "request docking", followed by a ";". No problem. Worked great for hours. However, for some reason, now if I say "docking request", she will say whatever she says, NOT open the left panel, and instead reverse the ship 6 m/s (or whatever the speed is). If I first say "open left panel" followed by "docking request", she will properly request docking and then perform the "look ahead" command.

    So I opened NotePad, set the program to activate on active window, and just said "docking request". What I found is that she types space, S, and space. Keep in mind, I remapped my game to follow your default mappings.

    If I first say "docking request", VA will recognize it, but say something akin to "command not recognized ((left panel))". I'm not at home right now, so I can't check exactly, but I'm sure you know what I'm talking about.

    This seems strange to me that I can say "open left panel" and have it work, but "docking request" fails to activate the ((left panel)) command, even though I can see the command in the drop down list of commands when modifying other commands (I only modified one command involving combat). Everything in the left panel works properly, such as saying "navigation" and "contacts", provided I first open the panel by saying "open left panel". I think it used to open just by saying "contacts", but I tried to figure out "docking request" for so long that I don't remember,

    Like I said, for almost every command, all I did was add more phrases for recognition. The ONLY command I modified was "Defence protocol beta", where I told it to power engines 4 pips and activate the ((afterburners)) command before beginning a jump, and that command never fails. The only command that fails is anything that has to use the ((left panel)) command without me first opening it. Actually, it might be the same for the right panel, but I never checked.

    This happened to me on my first instance of ASTRA, and I thought it was something I did, so after making a new profile instance and restraining myself to just phrases and Defence Protocol Beta, it still does it.

    Again, saying "open left panel" functions normally, and saying "docking request" after that will cause it to function normally and close the panel (provided I haven't manually interacted with the tabs, causing it to become lost). Just saying "left panel" does nothing, as it should. In my previous instance, I added basic commands to have the phrase "left panel" just open the left panel, but if I went to say "look ahead", it wouldn't function. I'd have to say "left panel" again. I just mapped it to press "1". I THOUGHT that was why it broke last time, which is why I just started a new profile, but apparently not, since I haven't added any new commands or done anything involving the left panel besides adding phrases such as "open left display" or "close left interface".

    I haven't said "open left panel" followed by "docking request" on NotePad yet, so idk what it would display then.

  • #2
    couple of things for you to check for me please:

    1. make sure you imported the profile correctly, read this: http://forum.hcsvoicepacks.com/forum...he-correct-way

    2. understand how panel tracking works, read this: http://forum.hcsvoicepacks.com/forum...-why-it-breaks

    3. edit your binds in elite, change something, save it, change it back afterwards if you wish...this sets it so the profile will read those binds. Check your binds are all correct whilst there When done say import my binds and test.
    The Singularity profile - One profile to rule them all and at HCS we bound them

    You see, TheThingIs, eventually you'll be allright.

    Comment


    • #3
      I have read those two posts of yours before, and followed the import steps when first setting up ASTRA. I understand how the panel tracking works, as it's actually tracking button presses since it has no access to actual Elite data. The only thing I haven't tried is turning typing mode on, getting the panels in proper position, and then running diagnostics. The fix could be as easy as that. I've gotten the panels in the proper position before, but then saying "docking request" sometimes causes it to open the Galaxy Map, so I'll have to try the "run diagnostics" solution afterwards. Perhaps I'm saying "open left panel" and then closing it manually, but I don't think so.

      What I don't understand is why restarting VA and restarting ED isn't fixing the problem. If doing the "run diagnostics" steps would fix it, shouldn't restarting both programs also have the same effect?

      I triple-checked the binds when I was setting up ASTRA, and I kept my HOTAS commands on the left, and her keyboard commands on the right. I suppose I should have said I use a HOTAS. I also usually don't type in the galaxy map. I just pick up missions, open the map from the missions panel, and plot a route. I never touch my keyboard.

      Comment


      • #4
        If I tell her to import the binds, will she import my HOTAS binds, or just the keyboard? If I like the binds where they are, should I just tell her to import the binds, or is there a reason I need to change them first?

        Comment


        • #5
          Idk if it was clear in my post, but I've complied with all recommendations to prevent it from breaking. Disabling menus on look, not typing in the Galaxy Map, etc. Everything I do should be a trackable action. And commands are sent directly to ED client.

          Comment


          • #6
            ....waaaaait a second. Maybe that's the problem? I mapped out the default keyboard commands, and therefore thought I didn't need to use the import bindings commands, and it's not able to track my HOTAS interactions? :O Genius!

            Comment


            • #7
              Wait a minute. No. I mean, it should help with some things, but it still doesn't explain why resetting both programs doesn't fix the issue.

              Comment


              • #8
                yes, starting the game and va from fresh is the same as run diagnostics..everything is in it's default state

                do a test for me please...go out into open space and log out of game, close va. Start va and then log into the game. Do nothing and say request docking...what happens?
                The Singularity profile - One profile to rule them all and at HCS we bound them

                You see, TheThingIs, eventually you'll be allright.

                Comment


                • #9
                  I started the game, commanded her to launch, then to retract landing gear, then to boost, and then I used my HOTAS to engage hyperspace. Throttled down in HS, logged out, and closed VA and the ED launcher. Reopened VA, reopened ED via Steam, logged in, began the game with the throttle at zero, touched nothing and said nothing, then said "request docking" and she said "requesting docking bay", never opened the panel, and put the ship in reverse for 6 m/s.

                  VA says "Recognized : 'request docking' (Confidence 100)" and "UNABLE TO EXECUTE COMMAND, 'left panel' (by name). COMMAND NOT AVAILABLE."

                  Comment


                  • #10
                    It seems it may be skipping over the "Contacts" command line. If I just say "Contacts", she says "Navigation", doesn't open the panel, and VA says it recognized 'contacts' (Confidence 96), but says the exact same line about the left panel command.

                    Comment


                    • #11
                      I assume your test was to determine if it's able to detect whether or not I'm in "normal space", and since she executed part of the command instead of ignoring it, it doesn't appear it is able to.

                      When I opened the panel again and gave it the docking command, it was able to comply, even when I moved back to the navigation tab from the Contacts tab with the HOTAS. Of course, since I'm in hyperspace, she goes to the Contacts tab and then can't do anything because it's blank. She also can't perform the "look ahead" command afterwards, since I have to manually open the panel.

                      Comment


                      • #12
                        Actually, correct that. I'm not in hyperspace. I'm just sitting here at 0.

                        It's also doing it with the right panel. When I say "cargo hold", she says "status" and doesn't do anything. VA recognizes "cargo hold" at 95 confidence, but it says "UNABLE TO EXECUTE COMMAND, 'right panel' (by name). COMMAND NOT AVAILABLE."
                        Last edited by CommanderBoy; 07-21-2017, 04:44 AM. Reason: Because I'm making too many replies. My bad.

                        Comment


                        • #13
                          There is something strange happening at your side, that's for sure.

                          Would you please be so kind do make screenshot of your VoiceAttack. Start Voice Attack and say nothing, just when it opens please make a screenshot of VA Window. (you can use https://snag.gy/ for picture upload it has instructions how to do that)

                          then please open Elite control options and scroll down to Interface mode category and make a screenshot of it as well and provide that screenshot too.

                          Those two can shed a bit more light on your issue for us to troubleshoot it.

                          Comment


                          • #14
                            https://snag.gy/3kLvMp.jpg This is the profile it loads first every time I open VA (the profile I made before buying ASTRA), so I have to switch it to this https://snag.gy/bUASwo.jpg , which is my second ASTRA profile, after I thought I broke the first one. Hence why it's got a "-1" in the name. And this https://snag.gy/Xm3v2Q.jpg is a picture of my Interface mode mappings. I would be delighted to hear I made a simple, glaring mistake, lol.

                            Comment


                            • #15
                              The first screenshot you have shown indicates a non-standard profile and as there is no version number or copyright notice I can tell it isn't working correctly. The 2nd looks ok but which profile did you test with? Either you have edited it or you have loaded the profile incorrectly. Also, to get an UNABLE TO EXECUTE cmd means something is wrong with the profile. Import a fresh copy (you don't have to delete the one you have), don't make any edits and do the same test again please using the fresh, unchanged profile.
                              Last edited by TheThingIs; 07-21-2017, 09:12 AM.
                              The Singularity profile - One profile to rule them all and at HCS we bound them

                              You see, TheThingIs, eventually you'll be allright.

                              Comment

                              Working...
                              X