Announcement

Collapse
No announcement yet.

Having voice command problems with ASTRA.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having voice command problems with ASTRA.

    I have updated HSC Tools and ASTRA voice pack to the latest versions. I have trained my voice recognition profile numerous times. I am running the Singularity Profile.When I run VA, all looks good. I start up Elite Dangerous Horizons and start the game. My problem is that most of the Voice commands work ok but some don't. Things like Launch, Star-port Services, System Map, Galaxy Map and many others work ok. Return to surface does not work. I launch and say Landing Gear up and it works ok but Landing Gear Down does nothing. Cargo scoop does nothing, Night Vision does nothing. I have checked for missing Key Binds and all looks good. I have tried uninstalling and re-installing HCS Tools and Astra many times and still have the problem. I'm at a lost for a solution to this problem.

  • #2
    Are the commands getting recognised but nothing is happening; or are they just not appear in the VA log as "recognised"?
    1) I reject your reality.... and substitute my own
    2) Not to be used when upset... will void warranty
    3) Stoke me a clipper i will be back for dinner
    4) Never tell Gangrel to do anything... he will probably get it wrong
    WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

    Comment


    • #3
      When I say the command, they just don't appear in the VA log.

      Comment


      • #4
        ok, in that case you might have to enable/disable adaptive recognition in the VA settings -> Recognition tab.

        Also enable/disable the adaptive recognition/acoustic echo cancellation can help
        1) I reject your reality.... and substitute my own
        2) Not to be used when upset... will void warranty
        3) Stoke me a clipper i will be back for dinner
        4) Never tell Gangrel to do anything... he will probably get it wrong
        WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

        Comment


        • #5
          Ok. I have tried your suggestion. I tried Disable Adaptive Recognition. I tried Disable Acoustic Echo. I tried with both on and both off. Still doing the same thing. It recognizes most commands but still not others.

          Comment


          • #6
            I would recommend having the "minimum unrecognised confidence value" being taken down to 0, so that it shows *all* commands (if successful or unsuccessful) that it recogjnised

            So if it doesn't appear even in that instance, then VA itself is having issues recognising trigger words
            1) I reject your reality.... and substitute my own
            2) Not to be used when upset... will void warranty
            3) Stoke me a clipper i will be back for dinner
            4) Never tell Gangrel to do anything... he will probably get it wrong
            WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

            Comment


            • #7
              Ok. I set it to 0 and still not working with some commands. Thanks for all your help so far..

              Comment


              • #8
                with the "minimum unrecognised confidence value" set to 0, are you saying that the commands are not even appearing in the VA log window?

                Do you have "Quiet log mode" enabled in the voice attack settings (Advanced tab). If so, can you disable it.
                1) I reject your reality.... and substitute my own
                2) Not to be used when upset... will void warranty
                3) Stoke me a clipper i will be back for dinner
                4) Never tell Gangrel to do anything... he will probably get it wrong
                WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

                Comment


                • #9
                  Hello. I uninstalled VA, HSC tools and Astra Voice Pack. I then re installed everything. I fired up VA and everything looked ok. I checked the Options and Enable Log Quiet is unchecked. I fired up ED and Astra said Welcome back. I said launch and the command worked fine and was visible in the VA window. I then said Gear up. I saw Gear Up in the VA window and the gear went up. I then said Gear Down and nothing in the VA window and the gear did not go down. It seems that it recognizes some commands and not others. I still cannot figure it out.

                  Comment


                  • #10
                    Does anyone have any suggestions? It was working fine before I did the update..

                    Comment


                    • #11
                      The only thing that I would suggest is double checking to ensure that all of the keybinds that we require are present in the control scheme.

                      http://forum.hcsvoicepacks.com/forum...fault-keybinds

                      Currently missing from said list:
                      Keyboard bind missing in Elite: Flight throttle: Forward only throttle reverse
                      Keyboard bind missing in Elite: Miscellaneous: Charge ECM
                      Keyboard bind missing in Elite: Miscellaneous: Weapon colour
                      Keyboard bind missing in Elite: Miscellaneous: Engine colour
                      Keyboard bind missing in Elite: Miscellaneous: Night vision
                      Keyboard bind missing in Elite: Mode switches: Switch HUD mode
                      Keyboard bind missing in Elite: Drive throttle: Forward only throttle reverse
                      Keyboard bind missing in Elite: Playlist: Play / Pause
                      Keyboard bind missing in Elite: Playlist: Skip Forward
                      Keyboard bind missing in Elite: Playlist: Skip Backward
                      Keyboard bind missing in Elite: Playlist: Clear Queue
                      Keyboard bind missing in Elite: Full Spectrum system scanner:Enter FSS mode
                      Keyboard bind missing in Elite: Full Spectrum system scanner:Leave FSS
                      Keyboard bind missing in Elite: Detailed surface scan:Exit mode
                      Apart from that, If the command is not appearing in the VA log window (even with "Unrecognised minimum confidence value" set to 0 ) .

                      The only other thing is to ensure that you are using the correct commands. If you look in the voice trigger editor (inside the csutomiser) it will give you a list of the commands. To access the customiser, you can say "Protocol override customise my settings" or press LeftAlt+LeftShift+LeftCtrl+Enter
                      1) I reject your reality.... and substitute my own
                      2) Not to be used when upset... will void warranty
                      3) Stoke me a clipper i will be back for dinner
                      4) Never tell Gangrel to do anything... he will probably get it wrong
                      WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

                      Comment


                      • #12
                        Open Task Manager and look to see if you are CPU bound.

                        Comment


                        • #13
                          Thanks for the info. I opened Task manager and the CPU is running at 15% and GPU at 45% .
                          I have an AMD Ryzen 7 3800X running at 4.2 GHZ with 32 gig of 3200 MHZ RAM, an EVGA 1070 GPU and an Asus Prime motherboard. Everything was working fine before I updating VA, HCS Tools and ASTRA to the latest versions. On the older version, all worked good. Something has changed in the new Versions but I cannot figure what it is. Like I said most commands work and show up in the VA window and others don't. When I run the Missing Key Bind Report, it says Binds selected in Elite HCS SaitekX52 "You have no missing or incorrect keyboard binds ". I check the Key binds in Elite and all keys are bound. I have train my speech at least 10 times now. I have not given up yet but I am running out of things to try. Thanks for everyone's help so far. I am looking forward to getting an Oculus Rift S in the near future and it would be nice to get VA working 100% as it was before the updates.

                          Comment

                          Working...
                          X