Announcement

Collapse
No announcement yet.

Newest ASTRA update - Some commands recognised but no action taken

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newest ASTRA update - Some commands recognised but no action taken

    A few days ago I had to fix my ASTRA voice pack after realising the 'on my mark' command wasn't working because I hadn't installed the update properly. While this is working fine now, I've come across a new issue. Some commands (notably 'launch' and 'disengage' right now) are listed as recognised in voice attack, but no action is taken beyond that. No sound response, no action in-game.
    e.g.
    Recognized: 'launch'
    Recognized: 'disengage'
    Recognized: 'prepare for launch'
    Recognized: 'disengage on my mark'

    There also seems to be some plugin command that's running occassionally that doesn't seem to be doing anything either.
    Plugin command: 'MessageCheck'

    I tried uninstalling and reinstalling both ASTRA and the plugin, I turned off the joystick 'push to talk' setup that I was using, but it still wouldn't work. What could be causing just these commands to not properly respond when everything else is? Is it's a new bug then hopefully it will be fixed in the next update (I'm still able to play without those commands). If not, what else should I do to try and fix this? (running VoiceAttck in administrator mode btw, just so we can skip that suggestion).

    Cheers for any help.

  • #2
    UPDATE: Disengage command suddenly working again. Launch still not working, and now neither is lights on/off (both recognised, just no response). System map command is also not being recognised despite being listed in the commands. I think ASTRA may have gained sentience on my machine and has started being mischievous :P

    Comment


    • #3
      Does the UI move at all when you give the command for Launch.

      Make sure that a keyboard input is assigned to the UI moment actions.
      1) I reject your reality.... and substitute my own
      2) Not to be used when upset... will void warranty
      3) Stoke me a clipper i will be back for dinner
      4) Never tell Gangrel to do anything... he will probably get it wrong
      WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

      Comment


      • #4
        First thing to check:
        Are you using the latest VoiceAttack beta version 1.6.1.27? It's listed in VoiceAttack download page on the right side:
        http://voiceattack.com/Default.aspx#download-1


        Lights commands will work only if you are in normal space. It will not work when you're docked, in outfit 'garage', in supercruise or in hyperspace.

        If launch doesn't work then it probably means your journal plugin is not recognizing whether you're docked or not. Launch will not work if you're not docked.

        Be sure that you have applied latest mini patch for your profile:
        http://forum.hcsvoicepacks.com/forum...r-minor-issues

        Also when you issue "launch" voice command and nothing happens please switch back to windows, open voice attack window and press left ctrl + left shift + left alt + space and new line with red dot will appear in Voice Attack log saying your game state like:
        Game state: docked or
        Game state: normal space

        if it displays "docked" while you're actually docked and you're unable to launch then it might be something else which is blocking you.
        Be sure that you have keyboard bindings set for corresponding UI actions as explained in great video:
        https://youtu.be/ZSt1icGhP8E

        Regarding system map - it seems that you either have no key bound for that or that edbinds plugin hasn't read it properly. Did you issue "import my bindings" voice command and then tested how it works?

        One more thing just to be sure:
        Are you running VoiceAttack as administrator mode or as another administrator user (do you have to enter password for other administrator user whenever you run VoiceAttack or it starts in administrative mode whenever you click it?) If you are running VoiceAttack as another administrator user which is not your current one (many people run in standard user account for security reasons and switch to administrator account when they need to make some changes to the system) then it's not possible for VoiceAttack and HCS plugins to read the correct state of the journal and bindings.
        Although if you're receiving "Message check" in VoiceAttack it might be that your account is administrator account and that you're running just in elevated mode which is OK.

        Comment

        Working...
        X