Announcement

Collapse
No announcement yet.

Maximum impulse command issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maximum impulse command issue

    I know there was a previous topic about this but I have got a lot more information about it now (without being able to decipher the logic pattern of the command unfortunately)

    First up the max/full impulse command seems to have some sort of issue. The way it responds differs depending on whether normal space or supercruise.
    a) normal space
    So in normal space, soemtimes when saying "maximum impulse" it will recognise the command in VA as correct but yet instead of putting me into maximum speed forward, it decides to go maximum speed backwards. Then when I say it a second time it will again recognise the command correctly and put me into the actual desired state.
    b) supercruise
    When in supercruise it will recognise the command as correct yet put my speed to the lowest possible. I believe it is trying to do the maximum reverse like it does in normal space but since you can't go in reverse whilst in supercruise it just sets to lowest speed instead. then saying a second time it corrects itself

    now a secondary issue which I have noticed happening more recently. Engaging supercruise. I use the command "Engage Supercruise" all the time. Until recently never had an issue with this command. But recently it has recognised the command and for some reason throwing my speed into maximum reverse. Definately not a good or even possible way to actually enter supercruise since you need to be throttling at a specific positive speed.

    I am not sure if these two commands may have a connection together but it seems as though it could be possible since I think the "engage supercruise" command is also using the "maximum impulse" command silently to ensure at full speed for the supercruise. Again this is me just goign by what happens and not from attempting to work out the crazed logic web associated with the voicepack comamnd structure. I have tried to get it to send the output commands onto notepad, but not quite figured out exactly how to do it. I did set active window to notepad etc, but it didn't do anything. Nothing was put in the notepad. So help on getting that to sort correctly would be nice for future debugging needs.

    A side-suggestion, would it be possible to have an option in the customiser to tick that will get it to create a document that can create an output text file so that in future it's easier for debugging maybe? so that we don't ahve to worry about switching active window to a notepad and pressing the keys it would use in-game. I know it would be a benefit to both users and you developers too.

  • #2
    I've done some more testing with this cmd as I've not as yet been able to reproduce the issues you have described. I believe it is related to your keybind settings. Could you send me a copy of your binds file to thethingis@theqnn.com please. There is already the ability to output what keys are being pressed although it's linked with some other things I don't want to make public so I'll look to separating it out in the next update.
    The Singularity profile - One profile to rule them all and at HCS we bound them

    You see, TheThingIs, eventually you'll be allright.

    Comment


    • #3
      email sent

      Comment

      Working...
      X