Announcement

Collapse
No announcement yet.

Elite Dangerous Singularity - extremely slow keystrokes and laggy response time

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Elite Dangerous Singularity - extremely slow keystrokes and laggy response time

    Hi all,

    As always, awesome work, and I'm glad to see more and more new material coming to HCS.

    I have an issue with Voice Attack in general, and the only thing I use it with is Elite, and with HCS voice packs. So I've been on medical leave for a few weeks, and haven't had much opportunity to play, and have also been away from my apartment, so I haven't had access to the computer. When I left, Elite and Voice Attack with HCS voice packs were working just fine, with no appreciable lag or hesitation in response, and all the macro keystrokes were occurring at a reasonable pace. Upon my return, it's operating like a herd of turtles through a field of peanut butter. Elite did have a patch while I was gone.

    My keystroke speeds and panel operating speeds are set very low for quick responses as a diagnostic step. Additional profiles were all removed, and Singularity and EDDI were re-imported. There are only two profiles. Singularity, and EDDI, and Singularity has been set up to include commands from EDDI. I have "active window" targeted in voice attack, instead of the ED client specifically. I know from previous diagnostic steps that this is a way to get faster keystrokes out of it (I don't know why).

    I have even tried removing all voice packs, and HCS tools, and reinstalling one, as well as re-downloading the HCS tools portion as a standalone zip file. The only thing I haven't done is reinstall voice attack specifically. I'm not sure about the license key or if I can back that up.

    No matter how quick I've got the keyboard settings set, the keystrokes in the macros feel like someone's hunting and pecking for them. I've been trying to search around the internet the past week or so to find out of anyone else is having this issue, but I haven't found much on the topic, so sorry if this is a re-post.

    I'm not sure where the problem lies, but I'd like to start here if possible. Here's hoping someone can help.

    Thanks in advance, and have a great day! Keep up all the good work guys!

  • #2
    Open up the customiser and see what the keyboard press/duration/wait time are set to in the Keyboard Control section.

    I typically have mine set to 0.05 seconds across the board.
    1) I reject your reality.... and substitute my own
    2) Not to be used when upset... will void warranty
    3) Stoke me a clipper i will be back for dinner
    4) Never tell Gangrel to do anything... he will probably get it wrong
    WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

    Comment


    • #3
      I have them adjusted to some very low values indeed. Key is pressed for 0.05, pause when opening panels is 0.65, pause between key presses is 0.03, down from 0.06, and pause between GUI presses is 0.03, also down from 0.06. Again, nothing has changed from when it was working to the time that I got back and started this all up again, notwithstanding my troubleshooting steps. It still feels like there's almost a full second between each keystroke or UI change. Not to mention a delay of almost 2-3 seconds between the command being completed, and the voice response, and the voice response to the macro execution.

      I've also tried switching the game between full screen and windowed mode to see if that would make a difference. Sometimes it makes a small change in the timings.

      If you like, I can OBS out a short video and put it up on Youtube so you can see what I'm talking about, if that would help.

      Comment


      • #4
        It depends on what command this is for as well.. for some of them (in particular some of the more complex UI swapping), there is an artificial delay put in as well. But this is instead to ensure that the command works correctly for all people across the board.
        1) I reject your reality.... and substitute my own
        2) Not to be used when upset... will void warranty
        3) Stoke me a clipper i will be back for dinner
        4) Never tell Gangrel to do anything... he will probably get it wrong
        WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

        Comment


        • #5
          Thanks for your reply,

          I'm aware that some of your more complex scripts are using custom timings for purposes that make the AI seem as though it's talking and taking action appropriately, that would make a lot of sense, of course. But when a series of keystrokes is being run in a macro and those timings are deferred to what the user specifies in the customizer (and I've noted the timings above in my previous message), I would expect a faster run through than what I'm getting. Right now it's painfully slow. Some of the commands of particular interest have to do with power transfers and moving pips around, which is relatively simple, but no matter how fast I set the timings, it happens leisurely at best. Also of interest are docking requests. It takes at least 2 seconds to get a response, and when it does respond, it moves through the panels, again, much slower than what I have the keyboard timings set to. Finally, even doing something as simple as dropping the landing gear has a relatively long delay before I even get a response from the AI, and that's basically a gear status check and a single keystroke.

          Here are my specs, and some more troubleshooting for your consideration.

          Sepcs:

          CPU: Intel 3930K OC'd to 4.4GHz, at 1.315V
          Cooler: Corsair H150i Pro 360mm AIO...and LOTS of case fans.
          RAM: 32GB G-Skill DDR3 1600MHz
          Motherboard: Asus Sabertooth X79
          Video: 2x GTX 1070's in SLI (Game runs beautifully with load distributed between the cards)
          Sound: Sound Blaster Recon3D Champion with I/O Drive
          Storage: 2x Samsung 850 EVO 1TB SSD's in a RAID 0 configuration, 2x WD Caviar Black 7200RPM 750GB in a RAID 0 configuration, 1x USB 3.0 WD My Book 4TB for backup.
          PSU: Corsair RM1000x
          Peripherals: Corsair K95 RGB, Corsair Dark Core RGB Mouse, Thrustmaster T16000M FCS Flight pack with rudder pedals
          Display: Samsung U28E590 4K display on display Port, Samsung SMBX2331 at 1080P on HDMI
          OS: Windows 10 64-bit, build 1903
          Video drivers: 430.86 from June 2, 2019
          Elite Dangerous is up to date
          Voice Attack was 1.7.5, running as administrator
          EDDI v3.4.1rc
          HCS Tools v1.0.5 with plugins version 3.1.2
          Singularity 2.1.1

          Not the newest rig, but it runs with the big dogs even today.

          Troubleshooting steps taken today:
          - Removed and trained up a new voice recognition profile in windows -- No luck (shouldn't affect macro execution, I wouldn't think)
          - Removed all key bindings from the game and backed them up. Started blank, and manually re-created all bindings, verified only one file present in game folder with no old versions present. -- No luck
          - Disabled EDDI plugin -- No luck
          - Uninstalled EDFX shaders -- No luck (shouldn't affect it anyway)
          - Removed ASTRA, HCS Tools, AND Voice Attack. Restarted computer. Removed Elite, Horizons, and launcher. Downloaded a fresh installer, and installed the game fresh again, after backing up all settings. Reinstalled Voice Attack, currently 1.7.5.3-Beta. Reinstalled ASTRA, and selected "download and install latest HCS Tools." Re-imported Elite Singularity profile, and EDDI profile. Edited singularity to include commands from EDDI -- All of this gave me no luck

          I had considered rolling back my video drivers, or possibly my windows installation back to 1809 to see if this makes a difference, but I've already had a lot of time invested in this today trying to figure out why this performance lag exists. My next step is to upload a short private youtube video and demonstrate the lag I'm experiencing. I'm quite certain something has changed on my machine, because I see literally NO ONE ELSE mentioning this phenomenon. I may also try doing up an installation on my gaming laptop to see if the problem persists there as well, but I'd have to steam on that for a minute.

          I've racked my brain on this, and I'm open to some fresh insight if you all have any.

          Thanks, and have a great day!
          Last edited by Designated_david; 06-08-2019, 01:07 AM.

          Comment


          • #6
            Link to the video showing my troubles...

            https://youtu.be/_TfbGiJHTZI

            Comment


            • #7
              Am looking into this... I have noted a suggestion to see if it is possible for the commands/profile to be tweaked to remove/make smaller the "enforced delay" that we have, but no promises on that front.

              *edit* The delay between recognizing a command and *starting* the execution of it, that is set by a setting in voice attack itself (recognition delay, on the recognition tab of Voice Attack settings).

              It would have been useful to have had the window of VA visible as well, so that we could see what the delay there was for recognition. Some people have noted that shifting the process priority of Voice Attack has helped themselves as well (in some cases notably)

              I would also suggest looking into running the non beta version of voice attack as well.
              1) I reject your reality.... and substitute my own
              2) Not to be used when upset... will void warranty
              3) Stoke me a clipper i will be back for dinner
              4) Never tell Gangrel to do anything... he will probably get it wrong
              WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

              Comment


              • #8
                Thanks!

                I do usually run the non-beta versions of VA, and intend to roll back to 1.7.5, I just wanted to see if there would be a difference, and there was not. In terms of recognized command execution delay, it's set to (0) presently. The delay is effectively a little less than half a second, around what a human, or AI for that matter might perceive. VA is pointed to "Active Window" instead of the ED Client, as this normally yields even slower results.

                Sorry about not having the window present, I'll keep that in mind next time. Couldn't fly very well even without it there, as you can see. LOL!

                There are also a couple people in the Elite Dangerous Community forum on Facebook that are starting to pipe up about it too when asked.

                Anyway, thanks for looking into it, let me, and all those who read this know what you find. Good luck!

                Have a great day, and as always, keep up the good work guys!

                Comment


                • #9
                  I just want to add, this is what I was trying to explain on Discord a while back. Its not the voice command responce thats slow, its the exicution of the commands AFTER its recognised your voice input.

                  Its happened since VoiceAttack had its update a few months ago. its made it unbearable to use

                  VA 1.7.3 this was working Brilliantly
                  VA 1.7.4 was impossable, so many bottlenecks, slow to the point if timing out.
                  VA 1.7.5 was released litterally the same day and it made very little difference, it takes about 2-5 seconds for each command to exicute. "Prepair to Launch" takes about 5min to do all of its commands (no exaggeration)

                  I think this is a VA issue, as I tried creating my own simple VA commands and I was getting the same unbearably slow responces. I tried to log this with VA, but I don't think they got it, they was telling me to remove and re-setup my Voice recognition file - but thats not the issue, its the exicution of commands. The voice was recognised fine.

                  I don't kknow if you've got more Leverage with the VA devs, Gangrel ?
                  Last edited by Lord.Lethris; 06-27-2019, 10:00 PM.

                  Comment


                  • #10
                    Try changing VoiceAttack target to 'Active Window' instead of Elite Dangerous Client. Cleared the issue right up for me.

                    Otherwise follow this:

                    https://forum.voiceattack.com/smf/index.php?topic=64.0

                    Merrell

                    Comment


                    • #11
                      I've always had it set to active window, and I have deleted and recreated my voice profile in Windows.

                      I've also tried rolling back to VA v1.7.3, but the current HCS profile is only compatible with v1.7.5 or higher.

                      Still no luck. I'll try waiting for the most recent HCS update next weekend.

                      Comment


                      • #12
                        Originally posted by macrossmerrell View Post
                        That forum post is if your having issues with Speach Recognition.

                        In our case, the recognition is fine, its the speed of the execution of the commands/keystrokes AFTER its recognised your command.
                        Switching between active window and target window makes no difference.

                        Comment


                        • #13
                          Also seeing problems in this area. VA recognises the command, but there's a noticable delay between that and the command executing. The problem doesn't happen with a dummy non-HCS profile with 1 command (different to Lethris, oddly. I wonder what I'm doing differently).

                          What I've done is...
                          1) Opened Elite, left the station and parked my ship. VA is set to target the active window.
                          2) Switched Windows focus to Notepad++.
                          3) Spoke a Singularity command ('Open map', FWIW, but the issue isn't specific to that command)
                          4) Noted delay (0.5-1s, for me) between VA recognising the command and keypress.
                          5) Switched to a dummy profile that just presses the 'a' button in response to the command 'letter a'
                          6) Spoke my custom command
                          7) Noted no delay.

                          VA forum thread: http://forum.hcsvoicepacks.com/forum...-response-time
                          Last edited by Nazdakka; 07-07-2019, 11:01 PM.

                          Comment


                          • #14
                            ...also noted on VA bootup, the stage "Reading keybinds from Elite and checking for any missing..." takes about 3min. where as before it took about 5 seconds.
                            Here is the log from VA:

                            Code:
                            23:38:11 - Ready, waiting for you to log into Elite...
                            23:38:10 - Listening suspended
                            23:35:02 - Reading keybinds from Elite and checking for any missing...
                            23:35:01 - Setting game to Elite: Dangerous
                            23:35:00 - Number One:Eli, Helm Control:Astra, Tactical:Cleo, Engineering:Leo, Operations:Orion and Science:Eli
                            23:34:57 - You currently have 7 crew members aboard  and the Ships Cat
                            23:34:57 - Reading in Voice Triggers from template 'English'...
                            23:34:55 - Checking integrity of detected crew...
                            23:34:54 - Detecting the crew...
                            23:34:52 - Running diagnostic checks...
                            23:34:49 - Loading customiser settings...
                            23:34:49 - Initialising, please wait...
                            23:34:49 - VoiceAttack profile - (c) 2017-2019 HCS VoicePacks Ltd
                            23:34:49 - Singularity v2.1.1 - VoiceAttack v1.7.6
                            23:34:46 - Plugin 'HCS Plugin v3.1.2  - (c) 2016-2019 HCS VoicePacks Ltd' initialized.
                            23:34:46 - Plugin support enabled.
                            Also did a quick "Crew Command Roster"... it timed out trying to do the commands:

                            Code:
                            23:43:01 - Number One:Orion, Helm Control:Leo, Tactical:Eli, Engineering:Cleo, Operations:Archer and Science:Astra
                            23:42:53 - Science:Astra
                            23:42:49 - Crew command roster timed out
                            23:42:43 - Engineering:Cleo
                            23:42:15 - Tactical:Eli
                            23:42:04 - Helm Control:Leo
                            23:41:43 - Operations:Archer
                            23:41:36 - Organising the crew now...
                            23:41:36 - No repeat mode is on so the same crew will not be assigned twice
                            23:41:28 - Recognized : 'organise a crew'
                            23:41:21 - Recognized : 'crewman orion'
                            23:41:10 - Recognized : 'you're my number one'
                            23:41:02 - Recognized : 'crewman orion'
                            23:40:59 - Listening resumed
                            23:40:45 - Recognized : 'crew command roster'
                            Last edited by Lord.Lethris; 07-07-2019, 10:46 PM.

                            Comment


                            • #15
                              setting VA's target to Active Window is normally the fix for the keybind checker getting stuck or being very slow, I know some of you already have that set. We are looking into the problem but so far I have been unable to replicate the issue
                              The Singularity profile - One profile to rule them all and at HCS we bound them

                              You see, TheThingIs, eventually you'll be allright.

                              Comment

                              Working...
                              X