Announcement

Collapse
No announcement yet.

Elite Dangerous Singularity - extremely slow keystrokes and laggy response time

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    I'm not sure why your AV is fine with other profile keystrokes and not singularity keystrokes, they do the same thing. Both VA and HCS voicepacks are code signed verified programs so your AV shouldn't be having issues with them. Atleast you've found the culprit and we can look for a resolution. Which AV software are you using?
    The Singularity profile - One profile to rule them all and at HCS we bound them

    You see, TheThingIs, eventually you'll be allright.

    Comment


    • #47
      I agree its very odd. The only difference is my custom profile doen't utilize your plugin - Although I'm guessing the simple "launch" command on your side doesnt either?

      I am using "Trends Micro Maximum Security 15.0". I've turned off the "machine Learning" which is what tryes to guess if somthing is a virus or not. but that made no difference.
      I have also put a ticket into Trends Micro, because it conserns me that I have added VA/HCS/ED to the exempt list and its still trying to scan the keystrokes.

      Comment


      • #48
        Lord.Lethris I saw your video. Man! You're hurting worse than I was.

        I had gone kind of quiet while I listened to everyone else and their troubles, and what the HCS guys and the VA guys think about the possible causes and solutions, and was quietly listening to things I could try.

        Personally, I tried the cleanup command line options that were noted here via a Microsoft thread link earlier. Forgive me, I'm not in a position to quote it, but it had to do with a deployment file cleanup, and a system file checker. I did that, and found no issues. For all I can remember, it could have also been on the VA forum. If I can remember, I'll link it. It can't hurt.

        Also, I checked, rechecked, and did it again with regard to my audio settings in VA, and found nothing amiss. I have Active Window targeted, and "integrated components" is selected as audio output type.

        Another thing I was testing and taking note of was process performance. I did get a little bit of a spike in VA's process while using the Singularity profile, but only during startup. There were no unusual delays in reading bindings files or anything. It takes a minute, but that's fairly normal. There are a lot of key binds in the game.

        There was one other issue that had eluded me until I set task manger to show logical processes. I had turned hyperthreading off. When running flight simulators, Prepar3d in particular, the machine will actually use less memory (important due to the 32-bit 4GB VAS limit, for that app in particular), and because I'm a complete pleb, I forgot to turn it back on when I went over to other games. I really didn't notice a performance hit, but since this is something that's...well not light on her feet, but not terribly heavy, I figured hyperthreading could help the voice attack process along. I am going to test this now, and report back.

        As of last night, I had turned the keyboard timings WAY down, but not quite to 0 on any settings, and while VA feels more sporty, closer to what it was, it's not perfect. It's usable now, and "well patched" for the moment, but still not perfect. Again, I'll report back after I test the hyperthreading. TheThingIs that might be something you may try in order to duplicate these symptoms. I'm using a hex-core processor at the moment, a 3930K per my specs. I imagine you're all more updated than I am...but...

        While I wouldn't wish any of these troubles on anyone, and I hate to sound the wrong way with this, but I'm glad I'm not the only one. Makes me feel more sane.

        Good luck to all of you, and thanks again to the HCS guys for listening, and digging through your own code. Keep up the good work.

        Comment


        • #49
          As a point of note, and after watching @Designated_Dave's video - After shutting down my AV software and freeying up more than 50% of my CPU, I now get the same slowness @Designated_Dave gets in his video. It did indeed use to be a lot faster. However, I can cope playing at this speed for now.

          But I'm still willing to work with everyone on optomising this and figuring out why its going this slow now.

          I have got word back from Trends micro and they want to do a live support call to see whats happeing themselves.

          Edit: They just send me an email... they will call me at 11:30 PM Saturday Night.... 11:30pm..? **Facepalm**
          Last edited by Lord.Lethris; 07-11-2019, 07:22 PM. Reason: AV call time.

          Comment


          • #50
            I may have found something that could bring us to a resolution. When I disabled my Webroot SecureAnywhere and restarted Voice Attack, the response was instantaneous as opposed to the multisecond delays we have all been experiencing. The keybinds also took only a matter of seconds to read as opposed to a few minutes.

            Comment


            • #51
              There is somthing definitely funkiy going on with Singularity and peoples AV.

              I have a call with Trends Micro tonight, who will run some diagnostics to see whats going on. Maybe that'll help/
              Last edited by Lord.Lethris; 07-13-2019, 06:34 PM.

              Comment


              • #52
                So I just finished on the Phone to Trends Micro. They have no idea either. But they want to do a callback for further testing. They want to collect some log files and let there engineers take a look at whats happening.

                Its now 1:30am. I gotta be up at 4:30am - so Im off to bed.

                Comment


                • #53
                  One other thing I just found that made some things a bit quicker.

                  If you have Panel Tracking set up, and you should, then you want to clear the "Panel Tab Return" box in the Keybord Control

                  Click image for larger version

Name:	Capture.JPG
Views:	2
Size:	56.8 KB
ID:	28089
                  Attached Files
                  Last edited by GJ51; Yesterday, 03:06 AM.

                  Comment


                  • #54
                    Me and A Trends Micro engineer just spent 4hrs testing every AV process one by one whilst running HCS and VA - we concluded it is a specific Process Hook that is causing the slow down. (I’ll edit this later with the correct process name - the engineer is still on my PC)

                    Worryingly, the engineer said its a standard process with most AV software. And is likely to affect a few people running any form of AV/Mailware and trying to run VA.

                    As HCS and VA are code signed/Certified, What Trends Micro are going to do is engineer a Micro-Fix for their AV software so I (and anyone else running trends) stops seeing this lag with VA and HCS.

                    We are uploading 3gb’s worth of logs as we speak.

                    Yay for teamwork.!! 👍🏻

                    Comment


                    • #55
                      Maybe...

                      I'm beginning to think there's a lot more going on. I use Malware Bytes along with whatever they call what's on Win 10 Pro and today for some unknown reason, things were happening so fast that I had to go back into the keyboard setting and slow things down a bit to keep it from getting out of sync.

                      Methinks it may be something going on at the ED servers that might have sped up response times.

                      Who knows?

                      Comment


                      • #56
                        For the record, hyperthreading seemingly doesn't make a difference either way. VA does seem to use a bit less processor power, and work a little easier, but execution speed on macros is still about the same. So, no luck.

                        Also, the VoiceAttack thread noting the Microsoft cleanup link is here... Some of you may have already read and found it.

                        https://forum.voiceattack.com/smf/in...p?topic=2768.0

                        Comment

                        Working...
                        X