Announcement

Collapse
No announcement yet.

Singularity keeps turning VA listening on

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Singularity keeps turning VA listening on

    I have VoiceAttack set to listen only when I push a hotkey, to prevent voice commands executing by accident from background sound or casual conversation. But Singularity keeps turning VA listening back on. This happens during the Singularity initialization routine, but also seems to come on at other times while I'm playing Elite Dangerous. VA will start to recognize background sound or casual speech not directed at VA and Leo will start to respond. I have to stop playing and turn listening back off (the headset icon on the right of VA's main window). As you can imagine, this is a huge pain.

    I assume this happens because Singularity turns VA listening off sometimes to perform commands that shouldn't be interrupted, and afterwards turns listening back on. If so, the ideal fix would be for Singularity to store the state of VA listening before turning it off, so the state can be restored correctly.

    I tried creating a command called "((Experimental code startup))" containing the command "Stop VoiceAttack listening" so see if it would at least keep listening off after Singularity initializes. But it didn't make a difference. And it wouldn't help anyway for the other times that VA listening spontaneously comes back on.

    I've noticed this happening for the last few months. I think it came in a couple of versions ago. I just upgraded to the latest Singularity (v1.11) and it still happens.

  • #2
    In the customiser, Miscellaneous category:

    If you have "listening control at profile start up" ticked, then VA will always load up with the listening mode *disabled*.

    Apart from that, there are a few (just a few) commands that "override" the listening status of Voice Attack, but that is because they are there to *enable* listening with a voice command.

    If there are commands that break this rule, can you let us know... because in theory it shouldn't be happening.
    1) I reject your reality.... and substitute my own
    2) Not to be used when upset... will void warranty
    3) Stoke me a clipper i will be back for dinner
    4) Never tell Gangrel to do anything... he will probably get it wrong
    WARNING! Swedish wall-of-text hits you for bork-bork-bork damage!

    Comment


    • #3
      Thanks for the reply, Gangrel. "listening control at profile start up" is checked.

      I just restarted VA. It starts with listening off, but when initialization finishes VA's listening is turned back on.

      Comment

      Working...
      X