No announcement yet.

Hello. X4 problems with the new HCS Astra Voice. She won't connect and work in X4.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Seafireliv
    Hello. Sorry for my lack of reply. Forgot i'd also posted here. It's been solved and thankyou.

    Leave a comment:

  • Gangrel

    Open the HCS Customiser (To access the customiser, you can say "Protocol override customise my settings" or press LeftAlt+LeftShift+LeftCtrl+Enter)
    Click "Check for updates"
    Click "Update now".

    An updated profile will be downloaded for the X4 profile, which should fix this issue for you

    Leave a comment:

  • Gangrel
    When you start up Voice Attack with the "HCS - X4 (beta)" profile selected, what version does it report. It should be reporting in the main VA window something along the lines below.
    11:18:24.069 VoiceAttack profile - (c) 2017-2024 HCS VoicePacks Ltd
    11:18:24.069 X4:Foundations v2.00 (beta) - VoiceAttack v1.12
    11:18:23.307 Nahimic app detected. This may cause conflicts with VoiceAttack.
    This warning is informational only and can be turned off via the Options screen.
    11:18:23.247 VoiceAttack privileges not elevated. Pro Tip - If you are having trouble with key presses being recognized, try running as an administrator.
    This message is informational only. Right-click this message to stop seeing it.
    11:18:23.202 Plugin 'HCS Plugin v4.0.0 - (c) 2016-2024 HCS VoicePacks Ltd' initialized.
    11:18:22.680 Plugin support enabled.
    Also, the new "HCS - X4" profile cannot be edited by the user, so all I can assume is that you have something like the X4 profile assigned to load on start up in the main VA settings (Click the Wrench on the main VA window, first tab).

    Load profile on start up / Global profile should be assigned to a NON HCS profile (if you do have to have a profile load on start up), as this can cause issues when updating.

    Leave a comment:

  • Hello. X4 problems with the new HCS Astra Voice. She won't connect and work in X4.

    So you guys updated X4. I can barely believe it. I thought it would never happen. Thanks for doing it anyway. It's been a long wait. I immediately bought it yesterday.

    Perhaps I acted too fast, cos I keep getting this error whenever I start VA and it goes through its routine:

    Object reference not set to an instance of an object.

    I do not understand what this means. I've edited X4 commands and I still get this. On a run Astra willaudibly respond to commands, but not be able to make anything work in game.

    Now I have already been told to go Discord, but discord is really wacky for me to get on. It questioned my email. Then it wanted to confirm my email and then wouldn't accept it since apparently it's already taken, yes by myself! So I can't even confirm it. It was fine years ago when I was last there. Things must've changed with their Security, everything is to apparently keep me `safe`, so safe I can't even enter.

    My only choice is to make a new email which I really don't like doing, but then it said I changed emails too fast? What, this is only one change. I'm still trying to get access just to get help on this.

    So Discord is really a pain just to get on. All I can say is things must've changed since I was last on years ago. Discord cannot possibly be the only place to get help, surely?

    I'm losing hope of getting much help from here since the X4 section is dead, but I'm asking if anyone can help with this issue here with X4? Maybe if I post this on the Elite section, maybe they will know what's going on withe HCS VA error I'm getting?

    By the way I'm om the GOG version of X4 and am registered on Egosoft with the game.

    Last edited by Seafireliv; 03 May 2024, 05:31 PM.